Browsing to an issue fails with an error in Jira Mobile due to a duplicate field on a screen

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Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When attempting to browse to issues via the Jira Data Center and Server mobile app, you may receive an error when viewing the issue. The error message will be localized, some examples:

  • "Kann Vorgang Nicht Anzeigen"
  • "Can't Show the Issue"
  • "No se puede mostrar la incidencia"

and more.

Diagnosis

The Jira Data Center and Server mobile app uses the REST API to find issue data - so we'll need to find the issue ID to correlate with the logs. For an issue ABC-123, execute the following query from the database:

SELECT ji.id
FROM jiraissue ji
JOIN project p ON ji.project = p.id
WHERE p.pkey = 'ABC'
AND ji.issuenum = 123;

Once the issue ID has been located, check your Jira logs. If you're being affected by this problem, the following might appear in the atlassian-jira.log:

2019-09-12 11:36:13,254 https-jsse-nio-443-exec-12 ERROR user 111x11111x1 xxxxxxx xxx.xxx.xxx.xxx /rest/agile/1.0/issue/<issue-id> [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: Duplicate key com.atlassian.jira.rest.v2.issue.FieldMetaBean@da35fe0
java.lang.IllegalStateException: Duplicate key com.atlassian.jira.rest.v2.issue.FieldMetaBean@da35fe0

If you see such an error message, execute the following SQL against the database:

select f.name, i.fieldidentifier, count(*)
from fieldscreen f, fieldscreenlayoutitem i, fieldscreentab t
where f.id = t.fieldscreen
and i.fieldscreentab = t.id
group by f.name, i.fieldidentifier having count(*) > 1;

If this query returns any rows, proceed to the resolution.

Cause

The screen used by that issue has a field that appears more than once.

Resolution

Remove the duplicate field from the screen:

  1. Log in to Jira as an Administrator - then go to Jira Admin > Issues > Screens
  2. For each screen mentioned in the query, click "Configure" next to it
  3. For each field that's duplicated, remove the extra fields (each field must only appear once)
    1. Make sure to check multiple tabs - fields may appear there

In the event that the screen cannot be accessed through the UI, please see Duplicate key error in Jira server on creating issue via REST API or accessing Custom Fields page in JIRA for the alternative resolution (which removes the duplicated fields from the database).


DescriptionViewing issues in JIRA Mobile fails due to a duplicate field
ProductJira, JIRA Mobile

Last modified on Apr 24, 2024

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