Can't change Customer Request Type while creating a new issue using Automation for Jira
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
While using a "Create issue" action in automation for Jira, it is not possible to set Customer Request Type to a specific value. An error is given in the UI that Jira Service Management does not provide an API for this operation.
Diagnosis
In an automation rule, use "Create issue" action and and select Customer Request Type field to set value. The following error "Sorry, but changing the Customer Request Type is currently not possible, since Jira Service Management does not provide an API for this." will be displayed.
Cause
Create issue is not able to set the "Customer Request Type" on issue create using Jira Service Management API.
Solution
Use "Create Service Management request" action to create the new issue.