Cannot Add Users to Groups Due to a Null Group Name

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Symptoms

  1. User loses the ability to add users to specific groups. Whenever he clicks on the "Groups" link in the User Browser, it just says that the user is a member of all groups, even though they are not.
  2. Unable to delete an unnamed Group

Diagnosis

SELECT *
FROM GROUPBASE
WHERE GROUPNAME IS NULL

+-------+-----------+
| ID    | GROUPNAME |
+-------+-----------+
| 12345	| (null)    |
+-------+-----------+

Cause

The GROUPBASE table has a NULL entry.

Resolution

tip/resting Created with Sketch.

See JRA-22164.

  1. Run the following query against your database:

    SELECT *
    FROM GROUPBASE
    WHERE GROUPNAME IS NULL
    

    (info) This should return a result with a null group

  1. Correct the faulty entry from you database using this query:

    UPDATE
    GROUPBASE
    SET GROUPNAME = 'name'
    WHERE GROUPNAME = <id>
    

 

Always perform a backup of your database before running queries against it.

Last modified on Feb 26, 2016

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