Fix incorrectly set resolutions in Jira server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

There may be times where the resolution of an issue is incorrectly set and you wish to modify it. This article goes through the steps on how to modify it.

One or more of the following has occurred in your Jira applications:

  1. The application has somehow got into a state where the issue resolution is not Unresolved, rather it is blank.
  2. Bundled Project Issue Filters are not returning the appropriate results as the JQL is not being matched.
  3. Issues appears as Strike Through on the Activity Stream but not yet resolved or closed.
  4. An issue has a resolution for an issue that is not resolved.
  5. An issue is in the closed or done status, however it does not have a resolution.
  6. An issue is closed/done, but it still appears on the Assigned to Me.
  7. An issue is closed/done but it does not reflects on the Issue Summary Open vs Resolved Issue Chart.

In the example shown in the screenshot below, the issue is closed (in the "Done" status) but the resolution is empty:

Cause

This is known to be caused by either of the following:

  • The transition leading to the Closed status is either missing a post-function to set the resolution field, or it is configured with a post-function that sets the resolution field to an incorrect value
  • Adding the resolution field to a screen, then using that screen to modify the issue. The resolution will be forced to be entered as per the default System Field Configuration
  • Adding the Resolution field as required on the default screen
  • Defined a Resolution called Unresolved and associate with the issue itself.

Jira applications by default will mark an issue as Unresolved when the resolution field does not have any value on it. Similarly, if an issue does not carry any value on the Resolution Field, Jira applications will see it as not yet resolved.

Workaround

Workaround using Jira workflows

(info) For a alternative solution using Automation For Jira, please move on to the next workaround.

(warning) Before you go ahead with this solution, please make sure to make a backup of your Jira application data by following this Jira back up documentation, so that you can easily revert your changes back if necessary.

Here are the steps to implement this solution:

  1. Identify the name of the workflow used by the Jira issue(s) for which you need to fix the resolution
    1. Open one of the impacted Jira issue in the Issue View, and click, on the View workflow link
    2. Take note of the name of the workflow
  2. For this step, we will add a new transition to the workflow that will set the resolution field to the expected resolution value:
    1. Make sure you are still logged in as a Jira Administrator
    2. Go back to the page ⚙ > Issues > Workflows
    3. Scroll down to the workflow identified in Step 1, and click on the Copy button next to it
    4. Look for the copy of the workflow in the page ⚙ > Issues > Workflows and click on the Edit button next to it. This copy will be a temporary workflow that we will edit and use to fix the issue resolution field.
    5. Switch to the diagram view, then click on the Add a transition button to create a new temporary transition
    6. Let's call this transition 'Fix Resolution', and set From status and To status to the same workflow status (the status that the Jira issues with the incorrect resolution field are currently in). For example:
    7. After you add the transition, you should see it in the diagram view, leaving and entering the same status:
    8. Now click on the Post Functions link, and then click on the Add post function button 
    9. Add the Update issue field post function
    10. This time, instead of setting the resolution field to None like the steps above for Scenario 1, you should set it to the desired value, for example 'Fixed' or any resolution.

    11. Publish the workflow
    12. Go to ⚙ > Issues > Workflow Schemes, and scroll down to the workflow scheme associated to the type of the issue for which you wish to fix the resolution
    13. As explained in the documentation Configuring workflow schemes, associate the Issue Types to the new temporary workflow that we created and updated
  3. Let's now fix the impacted issues, using the new workflow we just created
    1. Open any impacted issue in the Jira issue view, and then transition them using the 'Fix Resolution' transition. This will reset the field to the desired resolution for all these issues
    2. Alternatively, you can use a Bulk Operation to edit all the impacted issues and transition them using the 'Fix Resolution' transition. This will reset the field to the desired resolution for all these issues
  4. After that, make sure to go back to ⚙ > Issues > Workflow Schemes and update the scheme so that the issue type is associated again to the original workflow


Alternative Workaround using Automation For Jira

If the application Automation for Jira is installed in your Jira application, you might want to consider this simpler alternative method:

  1. Identify the project of the Jira issue for which you need to edit the Resolution field
  2. Configure a new automation rule in the project
    1. For Jira versions lower than 9.0.0
      1. Go to Project Settings > Project Automation 
    2. For Jira versions from 9.0.0:
      1. Automation for Jira is bundled in Jira and rules are configured in a different page
      2. Go to Project Settings > Automation
  3. The rule will be configured as follows
    1. When: Manual Trigger
      1. Select which group(s) the user(s) who will edit the Resolution field should belong to (for example: jira-administrators)
    2. Then: Edit issue fields
      1. Choose Resolution as the field
      2. Set the value to the value of your choice (for example Won't Do)
    3. The rule should look like in the screenshot below
  4. After that, open an example of Jira issue in the issue view page
  5. Click on More.
    1. You will see a dropdown menu and if you scroll all the way down, you will see the name of the automation rule that you just created
    2. Click on the name of the automation rule: the rule will be executed and the resolution will be updated accordingly (in the screenshot below, the automation rule was named "Manually Edit Resolution"):


DescriptionThere may be times where the resolution of an issue is incorrectly set and you wish to modify it. This article goes through the steps on how to modify it.
ProductJira
PlatformServer

Last modified on Sep 25, 2019

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