CNAME records remain unverified even when correct values are added in the domain provider page

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.


Summary

CNAME records are not getting verified for sending emails on behalf of your domain (Security → Emails).

Environment

Jira Service Management Cloud.

Diagnosis

You have copied the correct values for the CNAME (Name and Value pair) and TXT records from the Atlassian DNS records page as seen in the following screenshot.

After 72 hours the CNAME records remain unverified but the TXT record has been verified as seen below:

Cause

It has been discovered that certain domain providers, such as GoDaddy, automatically add the domain name to the value copied for CNAME name values. This means that your actual CNAME name value becomes http://atlassian-xxxc0.domainkey.acme.com.acme.com, causing the CNAME records to not match and leading to verification failure.

Solution

For the CNAME name value column, remove the root domain from the record name by replacing atlassian-xxxc0._domainkey.acme.com with "atlassian-xxxc0._domainkey".

This step should be followed for all CNAME records. Once the correction has been made, the verification process may take up to 72 hours, so it's important to ensure the correct values are in place.




Last modified on Aug 18, 2023

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