com.atlassian.activeobjects.jira.spi plugin fails to load on Jira server startup

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

The following appears in the atlassian-jira.log:

2013-04-28 21:42:39,003 localhost-startStop-1 ERROR      [plugin.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.activeobjects.jira.spi' : Unresolved constraint in bundle com.atlassian.activeobjects.jira.spi [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=javax.sql)(version>=0.0.0.1_006_JavaSE)(version<=0.0.0.1_006_JavaSE)).  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D
2013-04-28 21:42:39,004 localhost-startStop-1 WARN      [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.atlassian.activeobjects.jira.spi'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.activeobjects.jira.spi
	at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:445)
	at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
	at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:215)
	at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
	at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
	at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:725)
	at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:178)
	at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:58)
	at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:671)
	at com.atlassian.jira.ComponentManager.startJIRA(ComponentManager.java:220)
	at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:212)
	at com.atlassian.jira.ComponentManager.start(ComponentManager.java:197)
	at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:23)
	at com.atlassian.jira.startup.DefaultJiraLauncher$3.run(DefaultJiraLauncher.java:105)
	at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:284)
	at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:169)
	at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:98)
	at com.atlassian.jira.startup.DefaultJiraLauncher.access$100(DefaultJiraLauncher.java:25)
	at com.atlassian.jira.startup.DefaultJiraLauncher$1.run(DefaultJiraLauncher.java:64)
	at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:33)
	at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:59)
	at com.atlassian.jira.startup.LauncherContextListener$1.create(LauncherContextListener.java:80)
	at com.atlassian.jira.startup.LauncherContextListener$1.create(LauncherContextListener.java:75)
	at com.atlassian.multitenant.impl.MultiTenantComponentMapImpl.get(MultiTenantComponentMapImpl.java:121)
	at com.atlassian.multitenant.impl.MultiTenantComponentMapImpl.onTenantStart(MultiTenantComponentMapImpl.java:165)
	at com.atlassian.multitenant.impl.DefaultMultiTenantManager$1.consume(DefaultMultiTenantManager.java:134)
	at com.atlassian.multitenant.impl.DefaultMultiTenantManager$1.consume(DefaultMultiTenantManager.java:131)
	at com.atlassian.multitenant.impl.DefaultMultiTenantManager.runForEachListener(DefaultMultiTenantManager.java:256)
	at com.atlassian.multitenant.impl.DefaultMultiTenantManager.startTenant(DefaultMultiTenantManager.java:130)
	at com.atlassian.multitenant.impl.DefaultMultiTenantManager.startAll(DefaultMultiTenantManager.java:203)
	at com.atlassian.jira.startup.LauncherContextListener.contextInitialized(LauncherContextListener.java:108)  <+5> (StandardContext.java:4791) (StandardContext.java:5285) (LifecycleBase.java:150) (ContainerBase.java:1559) (ContainerBase.java:1549)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.activeobjects.jira.spi [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=javax.sql)(version>=0.0.0.1_006_JavaSE)(version<=0.0.0.1_006_JavaSE))
	at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
	at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:417)

Cause

There are some errors in the caches (usually after a plugin upgrade). 

Workaround

Perform the following steps in order to recreate the plugins cache:

  • Stop JIRA;
  • Clear all contents of JIRA-HOME/plugins/.osgi-plugins;
  • Clear all contents of JIRA-HOME/plugins/.bundled-plugins;
  • Start JIRA again.
Last modified on Sep 25, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.