Comment reactions option is missing in the Jira Service Management project settings

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

The Comment reactions option is missing in the Jira Service Management project settings.

This feature should be available in Jira Service Management Data Center version 4.21 or later (reference here).

Environment

Jira Service Management 4.x.x or 5.x.x.

Diagnosis

The following is true:

  • The instance has Jira Service Management version 4.21+ and a Data Center license.
  • The feature is enabled under Jira Administration > System > Edit Settings (on the top right of the System page) > Enable emoji reactions option.
  • Issue is present for all users and all JSM projects.

Cause

The dark feature flag sd.comment.reactions.disabled is enabled.

Solution

Navigate to the Dark feature page (<baseURL>/secure/admin/SiteDarkFeatures!default.jspa) and check if sd.comment.reactions.disabled flag is set. If so, disable it and the comment reaction option should appear. 

If you cannot see the disabled flag from above, you can also try adding the feature flag sd.comment.reactions.enabled.

See this article for more details on toggling dark feature flags.



Last modified on Jul 3, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.