Comments from emails are added as internal on the customer portal

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

Comments made by reporter or request participants via email are added as internal on the customer portal.

Environment

Jira Service Management 4.x.x, 5.x.x

Cause

A Jira Core incoming mail handler is being used by the Service Management project. As described also in this bug, Jira Service Management interprets all comments as internal unless:

  • they were created in the Customer Portal
  • they were created in reply to an email notification by the reporter / a participant / an agent, and processed by the Service Management mail handler (Email channel)
  • an agent made a comment in Jira and selected the "respond to customer" (external) option
  • an agent changes any comment from internal to external by editing it in Jira
  • they were created before an existing Jira project was converted into a Service Management project

To summarize, the collaborators (non-agent Jira users) are not allowed to make public comments, unless they are acting as a customer (are the reporter or a request participant) and communicating in the Customer Portal or via email with Service Management incoming mail handler (Email Channel).

We have a suggestion request raised to be able to have public comments in Jira Core's mail handler that you can follow and cast a vote on:

Solution

If you would like to create issues and comments in Jira Service Management projects, it is recommended to use a Service Management mail handler rather than a Jira Core incoming mail handler.

Note that with this option you will need to have one separate email address per Service Management project.


Last modified on Aug 29, 2022

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