Connecting Microsoft Teams to Jira fails

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

When entering the Jira server's unique ID in Microsoft Teams, the following message appears: 

Please check if ... is valid Jira unique ID and Jira Server for Microsoft Teams app for your organization is installed. 

Cause

Cause 1

This may happen if the Jira unique ID is (or was previously) used for another integration between the Jira instance (or a copy of it in a different environment).

Cause 2

This message can also occur if the Microsoft Teams for Jira app is unable to make an outbound connection. To diagnose this, navigate to Administration (⚙) > Manage apps > Manage apps, then find Microsoft Teams for Jira Server in the list and select Configure. If the message Microsoft Teams connection is currently INACTIVE appears after the end of the list of instructions, there is a connectivity problem.

Solution

Solution 1

Re-installing the Microsoft Teams for Jira app will generate a brand-new JIra ID. It is recommended to remove the application link to MS Teams service and also clear out database content for MS Teams plugin when re-installing it. This will ensure that a new Jira ID is created in Jira for the MS Teams connection.

Solution 2

Ensure that Jira is permitted to make outbound connections to the hostnames listed in the app's documentation: Jira Server for Microsoft Teams Help - Configuring firewall

Last modified on Apr 4, 2024

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