Creating new issues from the Customer Portal fails but issues are created anyway in Jira Service Management

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Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

  

Summary

When creating an issue through the Customer Portal in Jira Service Management, and error "Request could not be completed" is exhibited, but the issue's created anyway.


Environment

All versions of Jira Service Management 3.x and 4.x.

In Cloud this may also happen but the troubleshooting details below refer to the Server/DC versions.


Diagnosis

  1. An error "Request could not be completed" is shown on the screen when trying to create an issue through the Customer Portal.
  2. The issue is created anyway
  3. The failing Request Type's configured to have hidden fields in the form, and one of them is Epic Link or some other Issue Link type.
  4. (Server and DC) A message "You do not have permission to edit issue" is shown in the $JIRA_HOME/log/atlassian-jira.log right below the "Error creating issue" error:

    cat $JIRA_HOME/log/log/atlassian-jira.log* | egrep -i "/create/.*Error creating issue" -A1 | grep "You do not have permission to edit issue"

Cause

  • Linking an issue to another or to an Epic during creation is not an atomic operation nor a transaction: the issue gets created first then it's linked to the Epic or other issue. These two operations happen during the same browser request but are separate transactions, so if the latter fails, the first remains successful.
  • Also, linking an Epic is considered by Jira like an issue edition operation as far as permission go. When adding a "Story to and Epic" we are conceptually editing the Epic (increasing it's scope).

If the user creating the issue through the Customer Portal doesn't have edit permission on the Epic being linked to, the issue will be created anyway (albeit with an error message) and have no Epic Link.

Here are some possible causes preventing the user to edit the Epic

  • The Epic project's permission scheme doesn't include the user in the edit permission.
  • The Epic has a Issue Security Level that doesn't include the user.
  • The Epic has a workflow permission that prevents editions on it's current status.


Solution

There are some approaches to this situation. Some are just quick fixes to prevent the error and others are definitive fixes.

Quick fix: no impact

Remove the hidden Epic Link from the Request Type.

Quick fix: permission impact

Assess if the complaining users should have edit permission in the Epic's project and grant it to them (see possible causes for the permission failure above).

Definitive fix

This example solution is only for the sake of presenting an easy and quick alternative. You should evaluate it and see if it makes sense to your Jira customization or hire the services of an Atlassian Partner to assess your requirements and implement a more suitable solution to your needs.

If you indeed require the issue to be linked to the Epic but not that the users have edit permission in the Epic, an alternative is to use some automation to link the issues:

  1. Remove the Epic Link from the hidden fields in the Request Type
  2. Configure an Automation Rule that upon issue creation, matches the desired issues and links them to the right Epics. Configure this automation to run as a user with edit permission on the Epic.


Last modified on Aug 25, 2021

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