Customer notifications not sent from some Jira Service Management projects due to installed translation packs

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

Customer notifications are not being sent by Jira Service Management from specific projects.

Can also prevent Customer Notifications page from rendering properly.

Environment

Jira using Jira Service Management Translation pack

Diagnosis

Logs show error like the following

2020-10-10 18:40:17,075+0200 PsmqAsyncExecutors-job:thread-1102 ERROR admin     [c.a.jira.util.I18nHelper] Error rendering '${event.user.name} comentó:
    
    ${comment}': can't parse argument number: event.user.name
java.lang.IllegalArgumentException: can't parse argument number: event.user.name
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1429)
	at java.text.MessageFormat.applyPattern(MessageFormat.java:479)
	at java.text.MessageFormat.<init>(MessageFormat.java:380)
	at com.atlassian.jira.i18n.BackingI18n.formatI18nMsg(BackingI18n.java:246)
	at com.atlassian.jira.i18n.BackingI18n.getText(BackingI18n.java:149)
	at com.atlassian.servicedesk.plugins.lingo.internal.manager.LingoManagerImpl.getI18nTranslation(LingoManagerImpl.java:373)
	at com.atlassian.servicedesk.plugins.lingo.internal.manager.LingoManagerImpl.lambda$null$17(LingoManagerImpl.java:214)
	at com.atlassian.servicedesk.plugins.lingo.internal.manager.LingoManagerImpl.lambda$createLingoTranslationFromDefaultProvider$25(LingoManagerImpl.java:259)
	at com.atlassian.servicedesk.plugins.lingo.internal.response.LingoTranslationImpl.getContent(LingoTranslationImpl.java:63)
	...
Caused by: java.lang.NumberFormatException: For input string: "event.user.name"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:580)
	at java.lang.Integer.parseInt(Integer.java:615)
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1427)
	... 90 more

Cause

There is a bug in some translation packages for Jira Service Management that cause this problem.

On the example above, the problem was in the Spanish language pack, but there have been reports of other languages causing the same problems.

Best way to find the language is to read the message in the logs and deduce the language from it. 

Solution

Download Latest language pack .jar for the desired language for Jira Service Management in the link below

Upload the .jar file at the Manage Apps page in Jira's UI through the Upload App button.

If you don't have access to the above link, please contact Atlassian Support for assistance.



Last modified on Jun 13, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.