Deleted issue still appears in filter using JQL query
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Deleted issue still appears in queries
For example : issue with key DEV-1350
- Perform following query ;
project=DEV and issuekey>DEV-1348 and issuekey<DEV-1352
- Dev-1350 will appear under the search result
- However, when clicked, an error " Issue does not exist "
No error appears in logs
Diagnosis
Diagnostic Steps
- Perform a search through JIRA database
jiraissue
table, issue does not exist. select * from jiraissue where issuenum='1350' AND project=(select id from project where pkey='DEV');
1350 = issuenum
DEV = PKey
(substitute accordingly)
Cause
- Index cache is corrupted or not properly updated
Resolution
Perform the following:
Perform a full reindex, not a background reindex
- Stop JIRA
- Go to JIRA_HOME/caches/ and delete all the folders there.
- Restart JIRA
- Perform a full reindex