Deleted user from active directory is not synchronised in Jira Service Management application

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Deleted user is not synchronised in Jira Service Management with delegated LDAP

Diagnosis

We need to activate this user manually to resolve this issue.

  • We cannot manually activate this user as it is from LDAP.
  • We have to perform changes in database to activate this user.

Solution

  • As we need to perform changes in database to activate this user. Here are the queries to be executed to get this fixed.

SELECT u.id from cwd_user u where lower_user_name='USER_NAME';

UPDATE cwd_user u set active=1 where u.id=USER_ID_FROM_FIRST_QUERY;

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.



Last modified on Nov 5, 2024

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