Deleted user from active directory is not synchronised in Jira Service Management application

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Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Summary

Deleted user is not activated in JSM with delegated LDAP

Diagnosis

We need to activate this user manually to resolve this issue.

  • We cannot manually activate this user as it is from LDAP.
  • We have to perform changes in database to activate this user.



Solution

  • As we need to perform changes in database to activate this user. Here are the queries to be executed to get this fixed.

SELECT u.id from cwd_user u where lower_user_name='USER_NAME' 
update cwd_user u set active=1 where u.id=USER_ID_FROM_FIRST_QUERY

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.



Last modified on Sep 9, 2021

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