Deleted user from active directory is not synchronised in Jira Service Management application
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Summary
Deleted user is not synchronised in Jira Service Management with delegated LDAP
- With reference to the KB article new or deleted users and groups from active directory are not synchronised in JIRA applications, manual synchronisation of the directory is must.
- If instance is using delegated directory, there is no way to manually synchronise the directory.
Diagnosis
We need to activate this user manually to resolve this issue.
- We cannot manually activate this user as it is from LDAP.
- We have to perform changes in database to activate this user.
Solution
- As we need to perform changes in database to activate this user. Here are the queries to be executed to get this fixed.
SELECT u.id from cwd_user u where lower_user_name='USER_NAME';
UPDATE cwd_user u set active=1 where u.id=USER_ID_FROM_FIRST_QUERY;
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.