Discovery Tool or Collector export to Cloud fails at the step to upload file to Media Server

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Discovery Tool or Collector export to Cloud fails at the step to upload file to Media Server 

Environment

Discovery tool 3.2.1 and above

Diagnosis

The token is valid, but the export to the Cloud still fails with the error below in the Discovery Tool or Collector's log.

6/11/2024 9:47:48 AM: [Normal] Start transport process.
6/11/2024 9:47:49 AM: [Normal] Token is valid
6/11/2024 9:47:49 AM: [Normal] Getting authentication to upload file to Media Server...
6/11/2024 9:47:50 AM: [Error] Error getting data from JSON: 
6/11/2024 9:47:50 AM: [Normal] Exceptions:


Cause

As stated in the network connection requirements for Assets Discovery, data is uploaded via HTTPS requests to https://api.atlassian.com and https://api.media.atlassian.com. In this scenario, https://api.media.atlassian.com is not allowed in the firewall and hence, uploading the scan result to Cloud was not possible.

Solution

Make sure the connection to both https://api.atlassian.com and https://api.media.atlassian.com are allowed from the Discovery Tool/Collector server. For more detailed information about the allow-list of certain domains and IP address ranges to ensure Atlassian cloud products and other services work as expected, please refer to IP addresses and domains for Atlassian cloud products.


Last modified on Jan 20, 2025

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