Discovery Tool or Collector export to Cloud fails at the step to upload file to Media Server
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Summary
Discovery Tool or Collector export to Cloud fails at the step to upload file to Media Server
Environment
Discovery tool 3.2.1 and above
Diagnosis
The token is valid, but the export to the Cloud still fails with the error below in the Discovery Tool or Collector's log.
6/11/2024 9:47:48 AM: [Normal] Start transport process.
6/11/2024 9:47:49 AM: [Normal] Token is valid
6/11/2024 9:47:49 AM: [Normal] Getting authentication to upload file to Media Server...
6/11/2024 9:47:50 AM: [Error] Error getting data from JSON:
6/11/2024 9:47:50 AM: [Normal] Exceptions:
Cause
As stated in the network connection requirements for Assets Discovery, data is uploaded via HTTPS requests to https://api.atlassian.com
and https://api.media.atlassian.com
. In this scenario, https://api.media.atlassian.com
is not allowed in the firewall and hence, uploading the scan result to Cloud was not possible.
Solution
Make sure the connection to both https://api.atlassian.com
and https://api.media.atlassian.com
are allowed from the Discovery Tool/Collector server. For more detailed information about the allow-list of certain domains and IP address ranges to ensure Atlassian cloud products and other services work as expected, please refer to IP addresses and domains for Atlassian cloud products.