Done or Resolved issues appear in a scrum board backlog
Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Issues that have been resolved (the resolution field is set to a value) appear in the backlog section of a Scrum board, while they are not expected to:
Environment
Jira Software Server / Data Center 7.0.0 and above.
Diagnosis
Checking an example of resolved issue, we can see that it is in the "Done" status:
Checking the board column configuration (accessed from the page Board > Configure > Columns), we can see that the Done status is mapped to a column that is not located on the far right:
Cause
By design, Jira Software does not display in the backlog section issues that are in a status mapped to the last column of the Scrum board configuration. If the status of these issues is mapped to a column that is not on the far right, such issue will show in the backlog.
Note that the issue key will have a strikethrough which is normal (and has nothing to do with the column configuration), since the strikethrough simply means that their resolution field is set.
Solution
To ensure that resolved issues are not showing in the backlog, their status needs to be mapped to the last column (column on the far right).
Using the board column configuration from the Diagnosis section as an example, you have 2 options:
- Either move the column the Done status is mapped to, to the far right:
- Or move the Done status to the column that is on the far right:
After you do that, the backlog page will stop showing the resolved issues (assuming that all the resolved issues that were originally showing were in the Done status):
In case this did not resolve your issue then you may experience the issue as described here:
Issues are not showing in Kanban board