Duplicate Approve / Decline button and content in Approval email notification in Jira Service Management
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*Except Fisheye and Crucible
Summary
Approvers are receiving duplicate Approve / Decline button and possibly duplicate notification content in the Approval email notification, such as below
Diagnosis
- Project > Project settings > Customer notifications > Approval required is configured and enabled
- Project > Project settings > Automation has an automation rule configured to send emails to approvers upon Approval Required
Cause
When both Customer notifications and Automation are configured to send email to approvers when approval is required, both of them will be merged into a single email resulting in possibly duplicate content (depending on the content of the template in each configuration) and also duplicate buttons (if both templates are using $(approval.buttons))
Solution
Either disable the default 'Approval required' customer notification OR disable the automation which sends email to approver.