Emails to OpsGenie displays Chinese characters in alert description
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When configuring email integration in OpsGenie following "Integrate your email with OpsGenie" if the incoming email uses any encoding other than UTF-16 or sends charset with any format other than UTF-16 body is added to the description field of the alert as Chinese characters:
Cause
If the encoding process which is done at the email client's end before sending emails to OpsGenie integration uses any encoding other than UTF-16 or sends charset with any format other than UTF-16 it causes the decoding process to fail in OpsGenie.
Solution
Use the below settings on the email client's side:
- Encode incoming emails with UTF-16. Or,
- Send charset in UTF-16LE format.