Error message "Invalid date format" for specific dates

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When entering a date value on date picker fields, you can face the error "Invalid date format. Please enter the date in the format X" even when entering the correct date format.

Cause

The error message appears only for some specific dates, and it happens depending on the user's timezone and the Daylight Saving Time (DST) related to that time zone.

On this example, we have the user's timezone set as GMT-04:00 Asuncion:



And the date used as example (October 02nd, 2022) is the starting date of DST in Asuncion, Paraguay:

Solution

At the moment, Java API does not distinguish this in their API, hence, Jira also is not able to handle this case.

We have some workarounds that can help:

1. Users can change their time zone to another one where DST does not apply. For example, change from GMT-04:00 Asuncion to GMT-04:00 Aruba.

Each customer needs to change their settings. On the Portal, users need to click on their profile picture on the right upper corner, click on Profile and then change the time zone:



2. Add a description to the field.

You can add a message on the field to inform the users:


3. Use a Date & Time picker field instead.

When selecting the date, choose a time different from the one which starts the DST:


Last modified on Sep 27, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.