Error when importing a CSV File to Assets - "invalid_file"

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

Sometimes, when creating a new Assets Import Configuration, an "invalid_file" may appear:

rlabs.insight.i18n.import.module.validation.invalid_file


Cause

The most common causes for this error are as follows:

  1. The file has a header column with no name. These can easily be identified when opening the file in a text reader by seeing two commas (or other separators) side by side in the first line:

    First Name,Last Name,Address,City,,
    Mike,Cannon-Brookes,Level 29/363 George St,Sydney,,
    Scott,Farquhar,Level 29/363 George St,Sydney,,
  2. There are two or more header columns with the same name. This can be trickier to identify in larger files, so opening it on a spreadsheet editor is advised:

    First Name,Last Name,Address,Address,City
    Mike,Cannon-Brookes,Level 29,363 George St,Sydney
    Scott,Farquhar,Level 29,363 George St,Sydney

Solution


Double-check your .csv file for the symptoms above and make sure they are corrected before attempting to upload the file again.

Last modified on Jan 29, 2024

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