Filter export only contains 1000 issues in Jira server
Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.
Problem
- From the Issue Navigator, exporting filter results to CSV only exports 1000 issues.
- Using REST API to get a filter result from your Jira applications returns a maximum of 1000 issues.
Cause
This is an intentional limitation on Jira to avoid performance-related issues such as an OutOfMemoryException.
Workaround
Perform your export in batches. For CSV exports from the UI this could be done using the "created" field or other criteria to split the result set into batches smaller than 1000 issues.
When using the REST API the startAt
and maxResults
parameters should be used to paginate the results, looping until the total number of records is reached. The total number of records is provided in the first response. Examples are available at JIRA REST API Example Query Issues.
Resolution
Jira can be configured to increase the limit or bypass it altogether.
Retrieving more than 1000 issues at once may result in an OutOfMemoryException for large result sets. This can cause database corruption or an application crash.
As of Jira 8.2, the memory problems no longer apply. We’ve changed the way the exported issues are stored in the cache, significantly reducing the amount of memory required during the export. If you're using Jira 8.2 or later, or one of the latest Long Term Support releases, you can safely increase the limit. For more info about this fix and the affected Jira versions, see this issue.
Here is a brief explanation of each configuration property:
jira.search.views.default.max
- This is the maximum value of issues exported by default when exporting/requesting a search result.jira.search.views.max.limit
- This defines the maximum limit for all users, regardless of modifications on the referred URL.jira.search.views.max.unlimited.group
- This property sets up a group that will be able to request an unlimited number of issues on a search result.
You can set these parameters through the UI, using the "Advanced Settings" in the Administration section.
- Go to: Administration > System > Advanced Settings
- Find jira.search.views.default.max and jira.search.views.max.limit
- Change the values as desired, and click update.
No restart needed.
To verify the parameters in the database:
select propertyvalue from propertystring where id=(select id from propertyentry where property_key='jira.search.views.max.limit');
select propertyvalue from propertystring where id=(select id from propertyentry where property_key='jira.search.views.default.max');
To bypass the default and export more records:
- Perform your search in the UI
- Copy the URL of the format link you choose in the Export menu:
- Paste this URL into the URL bar of a new browser tab.
- Change the tempMax parameter to the number of issues you want (up to the max limit). Members of the unlimited group can remove this parameter to export the entire result set.
- Click return or go from the URL bar to download the exported results.
Limitations
The group name cannot contain a space as reported in this bug: - JRA-26088Getting issue details... STATUS
The value of jira.search.views.max.limit
must be at least as large as jira.search.views.default.max
.
Instructions for JIRA 4.3.x and earlier
Another potential cause
If you have already performed the steps above and you’re still unable to export more than 1000 issues, check if you have the following third-party plugin:
It has a global setting of its own which can limit your export counts.
To change that value for the plugin you should:
- Select . > Apps
- Click Manage apps.
- Under XPORTER, click Global settings.
- Edit the first field "Maximum number of issues" as needed.
Note that it's a third-party plugin and thus outside the scope of support of Atlassian. Engage them directly if needed.