Filtering on or searching for objects in Insight leads to Error: Something went wrong. Contact administrator

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Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Trying to filter or search for objects in Insights leads to Error: Something went wrong. Contact administrator

Environment

Any Jira version with any version of Insight

Diagnosis

This happens after operations as

  • Deletion of objects
  • Deletion/change of attributes
  • Deletion of ObjectTypes

In the atlassian-jira.log file the following shows up:

2021-09-16 21:50:29,265+0200 https-jsse-nio2-8443-exec-300 ERROR direps11 1310x46305658x2 10vwkzs 10.58.121.106 /rest/insight/1.0/object/navlist [c.r.j.p.i.services.core.ObjectServiceImpl] RuntimeException:Unable to create a new instance of class MutableObjectBean
java.lang.RuntimeException: Unable to create a new instance of class MutableObjectBean

Cause


The application index of Insight has been corrupted

Solution

Please use following steps to clear the cache.

(Note that although no Data loss is expected, it is always recommended to backup Jira before proceeding):

  1. Shut down Jira 
  2. Clear plugin and tomcat caches by removing the contents of these directories:
    1. JIRA_HOME/plugins/.osgi-plugins/
    2. JIRA_HOME/plugins/.bundled-plugins/
    3. JIRA_INSTALL/work/
  3. If your Insight is configured to "Restore Insight index from file" - please remove this file, so Insight will re-index upon start (the file should be located in the path  /var/atlassian/application-data/jira/caches/insight_indexes) OR $JIRA_HOME/caches/insight_indexes
  4. Restart Jira.
  5. Wait for Insight Re-Index to finish
  6. Try to filter/search again 


Last modified on Feb 23, 2022

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