Getting "We couldn't create the new mail channel as there is a configuration issue with the request type assigned for the email requests" error while enabling Jira Service Management mail channel

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

You cannot add/enable a Jira Service Management Customer Email handler.

Environment

Jira Service Management Cloud

Diagnosis

You receive the following error when trying to create a Customer Email Handler on a Jira Service Management project:

"We couldn't create the new mail channel as there is a configuration issue with the request type assigned for the email requests."

Cause

The error is due to the Request type that is associated with the Email handler having a few fields that are not supported (or, it's marked as required) for the email channel. 

Solution

You need to remove the required fields or make them optional (except Summary and Description fields) from the Request type under the Request form tab that is associated with the email channel. You can follow these steps to resolve it:

  1. From your service project, select Project settings > Request types > Select the Request type used by the Email Channel.
  2. Click on the Request form tab > Remove the field that is set as required (except Summary and Description) by clicking Remove.
  3. Or, mark it as not required by selecting No under the Required column > Update.

If you want to know more about the Jira Service Management email channel, please visit Receive requests from an email address.

Last modified on Aug 5, 2022

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