How to allocate the 'Jira Service Management - Customer' role in bulk?
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
We have seen issues where the 'Jira Service Management - Customer' role is not allocated to the Internal customer(with Atlassian account) post-migration from Datacenter/On-premises to cloud.
This article provides a workaround to bulk update users to the 'Jira Service Management - Customer' role.
Environment
- Jira Service Management cloud.
Cause
Recently JSM Introduced A dedicated product access role for internal customers in Jira Service Management. With this change, you will be able to select the appropriate product access role for new and existing users, allowing them to be either a "User (Agent)," "Customer," or "None."
Jira Administrators will be able to set granular permissions to control access explicitly.
However, there are some limitations as follows
- Post-migration from Datacenter/On-premises to cloud, internal portal customers who migrated from DC to the cloud will not get allocated with 'Jira Service Management - Customer.'
- Users syncing from the Active directory should have a customer role by default.
Solution
Obtain a list of the users that need to be bulk updated with the 'Jira Service Management - Customer' role
Now you have to options to choose to perform the bulk update
Use a free app called Bulkops to add users to groups on your cloud site.
Use Atlassian REST API Add user to group capabilities to add a user to a group.
NOTE: If we add customers in this "jira-service management-customers-yourSiteName," default group, they will automatically get the Jira Service Management - Customer" role.
- To obtain the groupId navigate to admin.atlassian.com > Directory > Groups
Select the group you wish to add the users to and copy the group ID from the URL