How to Edit the Resolution of a Jira Issue

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the server and data center platforms.

Problem

There may be times where the resolution of an issue is incorrectly set and you wish to modify it. This article goes through the steps on how to modify it.

One or more of the following has occurred in your Jira applications:

  1. The application has somehow got into a state where the issue resolution is not Unresolved, rather it is blank.
  2. Bundled Project Issue Filters are not returning the appropriate results as the JQL is not being matched.
  3. Issues appears as Strike Through on the Activity Stream but not yet resolved or closed.
  4. An issue has a resolution for an issue that is not resolved.
  5. An issue is in the closed or done status, however it does not have a resolution.
  6. An issue is closed/done, but it still appears on the Assigned to Me.
  7. An issue is closed/done but it does not reflects on the Issue Summary Open vs Resolved Issue Chart.

In the example shown in the screenshot below, the issue is closed (in the "Done" status) but the resolution is empty:

Cause

This is known to be caused by either of the following:

  • The transition leading to the Closed status is either missing a post-function to set the resolution field, or it is configured with a post-function that sets the resolution field to an incorrect value
  • Adding the resolution field to a screen, then using that screen to modify the issue. The resolution will be forced to be entered as per the default System Field Configuration
  • Adding the Resolution field as required on the default screen
  • Defined a Resolution called Unresolved and associate with the issue itself.

Jira applications by default will mark an issue as Unresolved when the resolution field does not have any value on it. Similarly, if an issue does not carry any value on the Resolution Field, Jira applications will see it as not yet resolved.

Workaround

Scenario 1

Use the below workaround for the following symptoms in your Jira applications:

  • The application has somehow got into a state where the issue resolution is not Unresolved, rather it is blank.
  • Bundled Project Issue Filters are not returning the appropriate results as the JQL is not being matched.
  • Issues appears as Strike Through on the Activity Stream but not yet resolved or closed.
  • The resolution field of a Jira issue has a value (for example: Resolved, Fixed, etc...) even though the issue is not Closed yet

(warning) Before you go ahead with this solution, please make sure to make a backup of your Jira application data by following this Jira back up documentation, so that you can easily revert your changes back if necessary.

Here are the steps to implement this solution:

  1. Identify the name of the workflow used by the Jira issue(s) for which you need to fix the resolution
    1. Open one of the impacted Jira issue in the Issue View, and click, on the View workflow link
    2. Take note of the name of the workflow
  2. Remove the resolution field from the configuration all the screens used in the workflow (identified in Step 1), except for the screens used to close/resolve the issue. This way, we will ensure that the resolution field will be only editable on the screen that users will see when they transition the issue to the Closed/Resolved/Done status. To do that:
    1. Login as a Jira Administrator
    2. Go to the page ⚙ > Issues > Workflows
    3. Scroll down to the workflow identified in Step 1, and click on the Edit button next to it
    4. Click on each transition, and check if there is a screen assigned to it
    5. If there is a screen assigned to it, click on the screen and check if the screen should or should not have the resolution field, and remove this field if necessary.
    6. For example, in the screenshot below, we can see that the "In progress" transition is associated to the screen "Comment Screen". If we click on the screen, we can see that the resolution field is included there, while it should not be the case, since this transition does not go into the Resolved/Closed or Done status:

  3. For this step, we will add a new transition to the workflow that will reset the resolution:
    1. Make sure you are still logged in as a Jira Administrator
    2. Go back to the page ⚙ > Issues > Workflows
    3. Scroll down to the workflow identified in Step 1, and click on the Copy button next to it
    4. Look for the copy of the workflow in the page ⚙ > Issues > Workflows and click on the Edit button next to it. This copy will be a temporary workflow that we will edit and use to fix the issue resolution field.
    5. Switch to the diagram view, then click on the Add a transition button to create a new temporary transition
    6. Let's call this transition 'Fix Resolution', and set From status and To status to the same workflow status (the status that the Jira issues with the incorrect resolution field are currently in). For example:
    7. After you add the transition, you should see it in the diagram view, leaving and entering the same status:
    8. Now click on the Post Functions link, and then click on the Add post function button 
    9. Add the Update issue field post function
    10. Choose the Resolution field and set it to None 
    11. Publish the workflow
    12. Go to ⚙ > Issues > Workflow Schemes, and scroll down to the workflow scheme associated to the type of the issue for which you wish to fix the resolution
    13. As explained in the documentation Configuring workflow schemes, associate the Issue Types to the new temporary workflow that we created and updated
  4. Let's now fix the impacted issues, using the new workflow we just created
    1. Open any impacted issue in the Jira issue view, and then transition them using the 'Fix Resolution' transition. This will reset the field to None for all these issues
    2. Alternatively, you can use a Bulk Operation to edit all the impacted issues and transition them using the 'Fix Resolution' transition. This will reset the field to None for all these issues
  5. After that, make sure to go back to ⚙ > Issues > Workflow Schemes and update the scheme so that the issue type is associated again to the original workflow

We also have an improvement request tracked for this under JRASERVER-11444 - Getting issue details... STATUS .

Scenario 2

Use the below workaround for the following symptoms in your JIRA applications:

  • An issue is closed, however it does not have a resolution.
  • An issue is closed but it still appears on the Assigned to Me.
  • An issue is closed but it does not reflects on the Issue Summary Open vs Resolved Issue Chart.

(warning) Before you go ahead with this solution, please make sure to make a backup of your Jira application data by following this Jira back up documentation, so that you can easily revert your changes back if necessary.

Here are the steps to implement this solution:

  1. Identify the name of the workflow used by the Jira issue(s) for which you need to fix the resolution
    1. Open one of the impacted Jira issue in the Issue View, and click, on the View workflow link
    2. Take note of the name of the workflow
  2. For this step, we will add a new transition to the workflow that will set the resolution field to the expected resolution value:
    1. Make sure you are still logged in as a Jira Administrator
    2. Go back to the page ⚙ > Issues > Workflows
    3. Scroll down to the workflow identified in Step 1, and click on the Copy button next to it
    4. Look for the copy of the workflow in the page ⚙ > Issues > Workflows and click on the Edit button next to it. This copy will be a temporary workflow that we will edit and use to fix the issue resolution field.
    5. Switch to the diagram view, then click on the Add a transition button to create a new temporary transition
    6. Let's call this transition 'Fix Resolution', and set From status and To status to the same workflow status (the status that the Jira issues with the incorrect resolution field are currently in). For example:
    7. After you add the transition, you should see it in the diagram view, leaving and entering the same status:
    8. Now click on the Post Functions link, and then click on the Add post function button 
    9. Add the Update issue field post function
    10. This time, instead of setting the resolution field to None like the steps above for Scenario 1, you should set it to the desired value, for example 'Fixed' or any resolution.

    11. Publish the workflow
    12. Go to ⚙ > Issues > Workflow Schemes, and scroll down to the workflow scheme associated to the type of the issue for which you wish to fix the resolution
    13. As explained in the documentation Configuring workflow schemes, associate the Issue Types to the new temporary workflow that we created and updated
  3. Let's now fix the impacted issues, using the new workflow we just created
    1. Open any impacted issue in the Jira issue view, and then transition them using the 'Fix Resolution' transition. This will reset the field to the desired resolution for all these issues
    2. Alternatively, you can use a Bulk Operation to edit all the impacted issues and transition them using the 'Fix Resolution' transition. This will reset the field to the desired resolution for all these issues
  4. After that, make sure to go back to ⚙ > Issues > Workflow Schemes and update the scheme so that the issue type is associated again to the original workflow

Alternate Method with Script Runner

This is an alternate method to clear resolutions on tickets

  1. Install the Script Runner add-on
  2. Build a search for all issues that are using the user created unresolved status
  3. Save search as a filter
  4. Use the built-in script to set items in that filter to any available resolution
  5. Remove the unresolved status listed under Administration >> Issues >> Issue Attributes >> Resolutions
DescriptionThere may be times where the resolution of an issue is incorrectly set and you wish to modify it. This article goes through the steps on how to modify it.
ProductJira
PlatformServer
Last modified on May 11, 2022

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