HTTP Status 405 Method Not Allowed - Jira

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

     

Summary

This error can be tricky to navigate, as it indicates that something has gone wrong without telling you why it occurred. This is an HTTP response status indicating that a web browser has requested access to one of your site’s pages.

In this scenario, your Jira has received and recognized the request, but has rejected the specific HTTP method it’s using. In practical terms, this means that the browser can’t access the page it requested. Users will see an error page, rather than the content they were looking for.

However, it has been observed some pattern of this behavior in Jira, where the HTTP Status 405  Method Not Allowed has been known to have related with:

  • Issues with System / Atlassian's plugin ( including Jira Software and Jira Service Management plugins it selves )
  • Issues with 3rd party plugins.

Environment

Jira Server / Data Center

Diagnosis

  • When trying to access some pages in Jira, it throws a HTTP Status 405 - Melhod Not Allowed in the page. It could happen when trying to access any Jira pages or any 3rd party plugin console pages:
  • On Administration > System > Manage apps > Manage apps you can find some disabled modules / apps, and you are unable to enable them in JIRA UI.
  • On the application.xml file from a Support Zip, you can locate one or more plugins in either DISABLED, INSTALLED or ENABLING status.

Cause

  • One or more System / Atlassian's plugin on DISABLED / INSTALLED / ENABLING status.
  • One or more 3rd party plugins on DISABLED / INSTALLED / ENABLING status.
  • Outdated System / Atlassian's plugin and/or 3rd party plugins
  • Incompatible 3rd party plugins
  • License issues of the plugins
  • Jira Service Management x Jira Software with different compatibility versions.

Solution

  1. Upgrade or remove all outdated plugins in the instance.
  2. Remove / Uninstall all incompatible 3rd party plugins
  3. Update / fix all the necessary licenses of the plugins
  4. Make sure Jira Service Management and Jira Software are on the same version as Jira Core. (info) The possible root cause of the version mismatch was upgrading the application using the Jira Core files. See more at: Jira applications compatibility matrix 
  5. Flush all the plugin’s cache and enable the plugins in the database level.

This last procedure will delete all the entries inside the pluginstate table, which in most of the cases it can be deleted. In case you have disabled a specific app for any reason, clearing the contents of this table will reactivate it. If you are not sure about it, it's a good idea to understand what might exist in the disabled state before clearing it out by running the following query in your database:

SELECT * from pluginstate;

Jira Server

  1.  Schedule a down-time
  2. Stop Jira. 
  3. Make a backup of your database
  4. Delete JIRA_HOME/plugins/.bundled-plugins; ( This folder will be re-created in the next start-up )
  5. Delete JIRA_HOME/plugins/.osgi-plugins; ( This folder will be re-created in the next start-up )
  6. Make a backup / delete the content of JIRA_INSTALL/work directory (only the content, keep the folder empty);
  7. Make a backup / delete the content of JIRA_INSTALL/temp directory (only the content, keep the folder empty);
  8. Run the following query in your database to enable the plugins which are in disabled state;

    DELETE from pluginstate;
  9. Start Jira. 

Jira Data Center

  1. Schedule a down-time
  2. Stop Jira. One Node at a time. 
  3. Make a backup of your database
  4. Delete SHARED_HOME/plugins/.bundled-plugins; ( This folder will be re-created in the next start-up )
  5. Delete SHARED_HOME/plugins/.osgi-plugins; ( This folder will be re-created in the next start-up )
  6. Make a backup / delete the content of JIRA_INSTALL/work directory (only the content, keep the folder empty) for each Node;
  7. Make a backup / delete the content of JIRA_INSTALL/temp directory (only the content, keep the folder empty) for each Node;
  8. Run the following query in your database to enable the plugins which are in disabled state;

    DELETE from pluginstate;
  9. Start the Nodes, one Node at a time.


Last modified on Feb 27, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.