Import completed but some object creation or updates didn't happen due to insufficient memory

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible


Summary

Insight import seems to have completed but not all objects that should be created are created, or expected updates on objects didn't happen due to insufficient heap memory.

Environment

Any Insight versions

Diagnosis

Warning about JVM memory low can be found in the <Jira_home>/log/insight_import.log of the day.

2021-05-26 12:13:37,457 [insight-InsightImportThreadGroup-worker-thread-1] | JVM Memory level low. Total JVM memory in system 2.1 GB, you still have 165.6 MB, which is 7.98% of total memory. Consider adding more memory to the JVM (-Xmx)

Cause

Some import steps weren't executed due to insufficient JVM memory

Solution

Increase Jira application memory as per Increasing Jira application memory. There's no one-size-fits-all but we have recommendations on the JVM memory size based on number of objects in Insight in System requirements.

(info) The recommended JVM memory in the documentation is to be added on top of the JVM memory size required for the Jira application to perform well. For example, if your Jira application is currently running well on 4GB JVM memory and you have about 10k objects, start with a total of 8GB JVM memory and increase gradually if needed.






Last modified on Nov 11, 2021

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