"Import Issues from CSV" option is missing from Issues menu
Problem
Direct option to open the Bulk Create Setup page is missing -
Go to Main Menu Issues -> Import Issues from CSV is missing.
Diagnosis
- Below permissions required to create issues in bulk using a comma-separated value (CSV) file is in place-
- Create Issue project permission
- Bulk Change global permission for the relevant projects
Reference - Creating issues using the CSV importer
2. The JIRA Importers plugin is updated and all required modules are enabled.
Jira Administration → Add-ons → Manage apps → Apply Filter All apps → System apps → Jira-importers-plugin
Reference - Importing data from CSV
3. The other option of CSV file import is working fine - Go to Jira Administration → System → IMPORT AND EXPORT → External System Import → CSV. It will open up the page for CSV File import.
Cause
Under Jira Administration → System → General configuration -> Advanced Settings there is a Property Key called "jira.bulk.create.max.issues.per.import" which is set to zero (0).
Resolution
- Go to Jira Administration → General configuration → Advanced Settings button and update the value for "jira.bulk.create.max.issues.per.import" key to 250(default value shipped with Jira). You can update the value as per your requirement as well.
- Refresh the page and click on Issues to see the missing option of "Import Issues from CSV" is available now. No need for restarting the Jira instance.