Insight ServiceNow integration imports does not import all the asset of each table at once.

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

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*Except Fisheye and Crucible

 

Summary

Insight ServiceNow integration only imports partial information, for example: Computers, Servers, Business Services;

While the ServiceNow instance has thousands of these (e.g. ~3000+) - the Integration imports less (e.g. 1756), and the numbers seem to vary with each import.

Environment

Insight ServiceNow integration 1.2.2

Diagnosis

  • Configuring the Insight ServiceNow integration, with Admin credentials, creating a Predefined Structure and configuration, will not sync the full scope of available assets in various tables.
  • Testing with ServiceNow Table REST APIs to get the same (e.g. using Postman) returns different results than Insight, and again, not the full scope of assets.

Cause

The REST API timeout in Servicenow is set by default to 60 seconds. If the datasest to import is large, the instance will timeout before the import was completed.

Solution

  • Possibly, if you run the import a few times, each run may add some objects.
  • Increase the REST API Timeout (e.g. 1-5 minutes trial and error) to allow Insight to get all the data at once.



Last modified on Jul 13, 2022

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