Issues are not getting created when sender is not part of the project
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Reference to Data Center article: Unable to create Jira issue using an Incoming Mail Handler because the sender of the email is anonymous
Summary
Issues are not created when using a Jira Incoming Mail Handler of type Create issues and comments from email. The desired effect is to create issues anonymously.
Diagnosis
After setting up the Mail server and Mail handler admins will perform tests. If the test emails don't reach the project there are various reasons for that. Here we will discuss the scenario when the sender doesn't have access to the project, thus being an anonymous sender. If the sender of the email doesn't have project access (e.g Team-managed Limited project), and Default Reporter field is empty - then no issue will be created in this project.
Cause
When investigating the logs by message ID, an error like that one is the cause:
message: Message with messageId=<[email]> has been rejected due to reason=Sender is anonymous and no default reporter specified. Message rejected.
The error is straight-forward.
Solution 1
Setup a Default Reporter with a user who has access to the project or communicate effectively to the users of the project that only the users with access will be able to create new tickets/comment from email.
Solution 2 - as mentioned in Receive emails from new users
Create an anonymous or dummy mail account on your mail server.
Create an equivalent anonymous or dummy Jira user account, whose email address matches the mail account you just created.
When configuring your mail handler options, set the Default Reporter to be the anonymous or dummy Jira user account.