Jira Cloud CSV Import Error: User Doesn't Exist
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Scenario 1:
The error occurs when you start a CSV Import from the External System Import option in Jira. This method does not show the pre-validations. However, you can click the 'Download Detailed Log' link to view the import details.
Error: Issue Creation Failed: User "<user displayname" doesn't exist
Scenario 2:
If you use Import issues from CSV functionality from inside a project, you will see the error below. This method shows a validation summary and displays any errors that may occur after the import is complete.
Environment
JIRA Cloud
Diagnosis
Check if the CSV file has Assignee, Reporter, and other User Picker Custom fields which have the user's Display Name as the value.
Cause
Jira cannot parse or resolve Display names in the CSV to email addresses or AAID(Atlassian Account ID).
We usually map Assignee column from the CSV file to the Assignee Jira field, which causes the error.
Solution
For Reporter and Assignee fields
In the CSV file used for the import, make sure that the Assignee ID and Reporter ID columns are present.
Go to the import function
(For Scenario 1) Go to Jira Settings > System, scroll down to Import and Export and select External System Import > CSV.
Note: If you are not a Jira Admin, you won't be able to use this option(For Scenario 2 ) Go to Project > All Work and select Import Issue from CSV from the actions menu.
Map the Assignee ID (Atlassian account ID) value of the CSV to the Assignee Jira Field. Similarly, map the Reporter ID value for the Reporter field.
Proceed with the import operation.
For Custom field - User picker fields
- These fields will not have the AAID Column for it in the CSV
- Change the Display Name in CSV to their respective user Email Address.
If you still face issues and require assistance, kindly contact the Atlassian Support Team.
