Jira is not capturing all emails

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

Jira is not retrieving all emails that a user sends.

After sending many emails to Jira or Jira Service Management, only a few mails are added to the issue as comments.

Diagnosis

Although Jira is properly configured and

  • is able to retrieve emails from the configured mailbox
  • Replying to an issue by email adds the comment on the Jira issue

When sending multiple emails at once, it fails to do so.

Cause

Jira Incoming Mail configuration "Messages Threshold" is set to a low value and Jira mail handler considers emails as 'Bulk'.

Resolution

On the "Incoming Mail" section (under System Administration) set the "Messages Threshold" to a higher value or set "Whitelisted Domains" to prevent it from happening to known email addresses.

The "Messages Threshold" can also be disabled by setting it to 0 but the previous options are recommended.

Last modified on Nov 23, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.