JIRA Issue History not Showing Changes for some Fields
Symptoms
When viewing JIRA's issue history, it seems to be omitting the history of certain fields.
For example:
- You can see that the Sprint field for an issue has been defined as "Sprint 1"
- When checking the issue's history, there is no indication of when this value had been defined as "Sprint 1"
Cause
- The issue history entries had been removed from the database
- A third-party plugin is blocking the issue history from being displayed, for example: Field Security Plugin for JIRA
Resolution
If the history has been removed from the database:
- The only method to recover this history would be from a backup before the change was made.
- Restoring this backup would also mean losing data between the time of backup until current day
If the history is being blocked by a third-party integration:
- Determine why the add-on is blocking your fields and configure it properly
- Or, disable/remove the add-on.
- In the case of the Field Security Plugin for JIRA, disabling this plugin will require a restart of JIRA to observe the changes.
In the case of JFS missing change history is generally caused by one of these:
- JFS patch is not applied properly to your JIRA instance (how to check: https://quisapps.com/confluence/display/JFS/Troubleshooting#Troubleshooting-EnsureJFSPatchforJIRAIsInstalled); patching is mandatory.
- JFS add-on state has been changed via UPM (aka Manage Add-ons) without JIRA restart. Please remember:
- You must restart your JIRA immediately in case of any change made to the JFS state via UPM. This includes installing, enabling, disabling, upgrading, uninstalling etc. of JFS add-on
- You also must restart JIRA immediately if you update the UPM add-on. Updating UPM causes reloading (i.e. disabling then enabling) of all user-installed plugins, including JFS, which in turn requires a JIRA restart.
Last modified on Sep 27, 2022
Powered by Confluence and Scroll Viewport.