Jira Service Management - Error Something Has Gone Wrong With Your Request. If Symptoms Persist Contact Your System Administrator
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The below error will pop up when creating issue at Service Management Customer Portal:
The following appears in the logs:
[servicedesk.internal.rest.CustomerWeb] Unexpected error creating request '[I18nErrorMessage(sd.portal.error.issue.wrong.request.type,List())]' : com.atlassian.servicedesk.internal.feature.customer.portal.WrongRequestType$
Cause
This error message appears when the preconfigured Jira Service Management workflow has been modified. We recommend against manually configuring your Jira Service Management workflow properties, as automation rules were introduced in Jira Service Management 2.4, which can be used to automatically transition issues when a comment is added.
Resolution
- Make sure all the issue types are mapped, from one transition to another:
- When Creating a new workflow Scheme, under Operations there is Assign.
- Clicking on assign opens up a new dialog box which lets you to choose which issue types this scheme can be associating with, better say you can map the issue types with your workflow scheme.
- In case you are using this Workflow scheme for Service Management project, you need to assign those Request Types to this workflow scheme because Service Management is working with Request Types.