Jira Service Management Fails to Start with a Timeout error after its Installation

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After installing Jira Service Management, it does not start with a timeout error:


The following appears in the atlassian-jira.log:

2015-01-07 16:32:25,206 TP-Processor19 INFO jirauser 992x302039x1 1vz9bny 192.168.1.1 /rest/plugins/1.0/com.atlassian.servicedesk-key [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.servicedesk, com.atlassian.plugins.atlassian-client-resource, com.atlassian.jira.plugins.workinghours], 60 seconds remaining
2015-01-07 16:33:24,459 TP-Processor19 INFO jirauser 992x302039x1 1vz9bny 192.168.1.1 /rest/plugins/1.0/com.atlassian.servicedesk-key [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.servicedesk], 0 seconds remaining
2015-01-07 16:33:25,459 TP-Processor19 INFO jirauser 992x302039x1 1vz9bny 192.168.1.1 /rest/plugins/1.0/com.atlassian.servicedesk-key [atlassian.plugin.manager.DefaultPluginManager] Disabling com.atlassian.servicedesk
2015-01-07 16:33:27,497 TP-Processor19 ERROR jirauser 992x302039x1 1vz9bny 192.168.1.1 /rest/plugins/1.0/com.atlassian.servicedesk-key [atlassian.plugin.manager.PluginEnabler] Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.servicedesk
2015-01-07 16:33:27,746 ThreadPoolAsyncTaskExecutor::Thread 61 ERROR jirauser 992x302039x1 1vz9bny 192.168.1.1 /rest/plugins/1.0/com.atlassian.servicedesk-key [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] Unable to create application context for [com.atlassian.servicedesk], unsatisfied dependencies: none
java.lang.IllegalStateException: Invalid BundleContext.
    at org.apache.felix.framework.BundleContextImpl.checkValidity(BundleContextImpl.java:365)
    at org.apache.felix.framework.BundleContextImpl.getServiceReferences(BundleContextImpl.java:307)

Cause

Jira Service Management was not successfully installed or the downloaded file is corrupted.

Resolution

  1. Stop Jira;
  2. Remove the jira-servicedesk-X.X.X.jar inside the $Jira-Home/plugins/installed-plugins directory;
  3. Restart Jira;
  4. Install Jira Service Management again through the Find New Add-ons page in the Jira Administration.

Last modified on Nov 6, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.