Jira Service Management mail handler creating empty comments
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using Outlook some comments created by the mail handler are empty
Environment
Jira Service Management 4.22.2 or higher (could impact earlier versions)
Diagnosis
Inspecting the e-mail that generated the empty comment we can see it is a forwarded e-mail to the Email channel account.
Checking Jira Service Management Email requests setting under Administration > Application > Jira Service Management > Email requests we can see 'Strip quotes' is enabled:
Cause
This is working as designed. When 'Strip quotes' is enabled the forwarded message should not be included on the comment.
To avoid the empty comment you can use the 'Don't strip quotes' option.
Note: Gmail works differently, and this is being tracked on bug JSDSERVER-12016