Jira Service Management tickets creating empty ticket description or comment
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Summary
When you forward an email you generally want the contents of the email copied over to the next recipient. That said, when an email is forwarded to another person and then submitted as an email request there is no email body/description added to the Jira Issue that is created, only the summary is added. This can cause confusion and mislead users as there is no content description or issue comment from the email request ticket.
Diagnosis
This scenario is caused when using the Strip quotes feature under Products > Jira Service Management - Email requests:
Cause
When email requests are submitted and Strip quotes is turned on, if any email contents are quoted, anything below that line will be removed from the email request, when created as a Jira Issue. Such as the following format of an email (from the email headers (downloaded EML file) with: quoted-printable indicating the text below it will be removed from the email request as a Jira Issue.
Content-Type: text/html;
charset=utf-8
Content-Transfer-Encoding: quoted-printable
<html><head><meta http-equiv=3D"content-type" content=3D"text/html; charset=3D=
utf-8"></head><body dir=3D"auto">This is a test<div><br></div><div>Thank you!<br><br><div dir=3D"ltr"><p di=
r=3D"ltr" style=3D"line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">=
Solution
You can either:
- Disable quoted text and include all email content, including forwarded email content.
- Always include the content you want above the line where the text is not quoted.