Jira service project comment added by reporter showing to be added by another user
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*Except Fisheye and Crucible
Summary
Comments added via email from the reporter on tickets in a Jira service project show to be added by another user in the comment section of the ticket. This behavior appears to be random as there are times when the comment is added with the correct owner and other times it is added with a different user account.
Environment
N/A
Diagnosis
This behavior occurs when a specific configuration has been applied with the following conditions:
- The sender of the email does not have application access
- An email request channel has been configured for the project to receive and process incoming mail.
- The same email address is used in a global mail server configuration
- A global mail handler has been configured to use the mail server above, has a default reporter set, and "Create Users" is not selected.
When looking at the "Processing log" for the email request channel you will find that when the comment is added by the reporter it is not registered in the log events
- Path: Jira Administration > Applications > Email channels > select "View log" for the email channel in question > select the "Processing log"
Cause
The cause for this behavior is due to over-configuring the email integration for the Jira service project. When setting up a "Email request channel" for a service project there is no need to also configure a global mail server/mail handler. When a global mail handler is configured to use the same mailbox as the email request channel it will result in multiple mail puller jobs pulling mail from the same mailbox. These mail pullers are set to run on a set interval but they don't run at the exact same time. If the mail puller for the global mail handler runs before the email request channel mail puller, while the email sent is in an unread state, then it will pull the email > mark it as read > and then it will be processed according to the global mail handler logic instead of the email request channel logic.
Why this is important is the global mail handler uses licensing requirements as it processes emails sent to the mailbox being used. If the sender of the email does not have application access (a Jira License) then it will either create a user account, if "Create Users" has been enabled, or it will use the "Default Reporter" to process the email. If a "Default Reporter" is not configured and "Create Users" is not enabled then the email will be rejected due to the sender not having a valid Jira license.
Solution
- Delete the global mail server/mail handler that is configured to use the same mailbox as the email request channel.
- After these have been removed the comments will be added to the ticket with the proper author consistently.