JIRA shows "JIRA is having difficulty contacting <Application>. If this condition persists, please contact your JIRA Administrators" message in the Development Panel
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When viewing an issue, you see the "JIRA is having difficulty contacting <Application>. If this condition persists, please contact your JIRA Administrators" in JIRA
The following may be seen in the atlassian-jira.log
2015-06-29 15:45:34,065 applink:thread-3 WARN admin 903x72x1 i2os9 10.80.103.100 /browse/TEST-1234 [core.auth.oauth.OAuthRedirectingApplicationLinkResponseHandler] Peer rejected the timestamp on our OAuth request. This might be due to a replay attack, but it's more likely our system clock is not synchronized with the server's clock. You may turn on debug logging to log the full contents of the OAuth response headers.
2015-06-29 15:45:34,080 applink:thread-4 WARN admin 903x104x4 i2os9 10.80.103.100 /rest/dev-status/1.0/issue/summary [core.auth.oauth.OAuthRedirectingApplicationLinkResponseHandler] Peer rejected the timestamp on our OAuth request. This might be due to a replay attack, but it's more likely our system clock is not synchronized with the server's clock. You may turn on debug logging to log the full contents of the OAuth response headers.
Diagnosis
JIRA and the other application are located in different servers
Cause
The time of both servers are not synchronised or one of them might have problems
Resolution
Check the time for both servers and synchronize them. If possible, install NTP and sync the servers time with it