JIRA throws Incompatible with product license when updating license
Platform Notice: Server, Data Center, and Cloud By Request - This article was written for the Atlassian server and data center platforms but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.
Problem
Add-on is disabled after updating either your JIRA license or Add-on license.
As an example of what you'll see when going to Manage Add-ons in JIRA:
Installed version: 7.5.3 Add-on key: is.origo.jira.tempo-plugin License details: 10-user starter license, Enterprise, expires 2016.08.05 License status: Incompatible with product license (wrong type) License SEN: SEN-XXXXXXXX
At this point, this has only been verified to happen when using a plugin by Tempo
Installed version: 7.5.3 Add-on key: is.origo.jira.tempo-plugin License details: 10-user starter license, Enterprise, expires 2016.08.05 License status: Incompatible with product license (wrong type) License SEN: SEN-XXXXXXXX
Diagnosis
- The user license tier applied to JIRA does not match the user license tier in one or more of Add-ons.
- You'll notice the message "Incompatible with product license
(wrong type)"
- You'll notice the message "Incompatible with product license
Cause
- The license tiers are incompatible.
Workaround
- Use an evaluation license in JIRA as a temporary solution until you get the licenses to match.
Resolution
- Upgrade the UPM(Universal Plug-in Manager)
OR
- Ensure the licenses match.
- You can Contact our Licensing and Billing team if you need assistance in ensuring the licenses match.
- Support Engineer to Include the plug-in vendor to the ticket if the first resolution didn't work, refer to Third Party Add-on Vendor Collaboration Registry