JQL search using SLA field fails with "You must have a licensed service project to run JQL queries on SLAs"

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When attempting to run a JQL search anywhere in Jira, you may encounter the error message "You must have a licensed service project to run JQL queries on SLAs." This prevents the proper results from being displayed.

Example of error message:

Environment

  • Jira Data Center with Service Management installed.

Cause

To perform searches using SLAs or other data specific to the Service Management functions in Jira, it is required that JSM is licensed and that the license is still active. 
If the JSM license expires or is removed from the system, you'll face this error when running JQL searches using SLA custom fields.

Solution

Go to the Jira Administration section on Jira administration (gear icon) > Applications > Versions & licenses and review/correct the license applied for Jira Service Management.

Last modified on Dec 29, 2023

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