Knowledge Base searches still use the old Application Link URL on the Customer Portal

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Symptoms

After changing the URL of the Confluence Application Link, the knowledge base links on Jira Service Management still points to the old URL. We're tracking this a bug on JSD-641 - Getting issue details... STATUS .

Diagnosis

Simply run the following SQL query in Jira's database to verify which is the URL in use by JSD:

SELECT * FROM "AO_54307E_CONFLUENCEKB";

Resolution

tip/resting Created with Sketch.

Always backup Jira before modifying its database.

  1. Stop Jira;
  2. Update the AO_54307E_CONFLUENCEKB table, and update the application link URL.
  3. Restart Jira;

For example, if updating the URL from HTTP to HTTPS, the following can be used:

This was created using PostgreSQL - if you're using a different DBMS you may need to update the query accordingly.

Last modified on Nov 23, 2020

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