Logging into JIRA is Slow and Requires Multiple Attempts
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
- The login process is slow and it might need multiple attempts to successfully access JIRA.
Diagnosis
- There is a load balancer in front of the Active Directory
- The following error can be found on atlassian-jira.log:
XXXX-XX-XX XX:XX:XX QuartzWorker-1 INFO ServiceRunner [atlassian.crowd.directory.DbCachingRemoteDirectory] delta synchronisation for directory [ 10000 ] starting
XXXX-XX-XX XX:XX:XX QuartzWorker-1 INFO ServiceRunner [atlassian.crowd.directory.DbCachingRemoteDirectory] synchronisation complete in [ 70000ms ]
XXXX-XX-XX XX:XX:XX QuartzWorker-1 ERROR ServiceRunner [atlassian.crowd.directory.DbCachingDirectoryPoller] Error occurred while refreshing the cache for directory [ 10000 ].
com.atlassian.crowd.exception.OperationFailedException: org.springframework.ldap.PartialResultException: nested exception is javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: somedomain:389 [Root exception is java.net.ConnectException: Connection timed out: connect]]
Cause
With a load balancer directing requests to multiple Active Directory servers, there are several reasons why a JIRA request will fail:
- Request is directed to a server that is not accessible to JIRA.
- Request is directed to a server that is geographically distant from the JIRA server, resulting in longer response times.
Workaround
- Ensure that all servers Active Directory servers integrated is accessible to JIRA
- Connect JIRA directly to one of the servers and bypass the load balancer.