Logging into Jira server returns 500 internal server error
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After upgrading JIRA
- You are unable to access JIRA
- You are unable to start plugins
- There are java.lang.NoSuchMethodError messages in the logs
The following appears in the atlassian-jira.log
java.lang.RuntimeException: javax.servlet.ServletException: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;
Caused by: javax.servlet.ServletException: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;
Caused by: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;
Diagnosis
- The following Add-ons has been confirmed to be incompatible and cause the above problems:
jira-workinghours-plugin-1.5.5
jira-calendar-plugin-2.1.11
ephor-for-jira-1.2.3
hipchat-for-jira-plugin-6.31.0
bugdigger-jira-plugin-2.5.1
whoslooking-2.1
Cause
JIRA changed to use a different class causing incompatibility by any Add-on still using the deprecated API.
Resolution
If you can access JIRA
Open the Manage Add-ons page by navigating directly to:
http://<jira-address>/plugins/servlet/upm
Replace <jira-address> with the actual address from your JIRA instance.
- Update or disable any add-ons displayed as INCOMPATIBLE.
- If the page above is not accessible and shows the same error, follow the steps under Resolution 2 below.
If the suggestion above does not work
- Stop JIRA
- Go to your the
$JIRA-Home/plugins/installed-plugins
directory Rename the
$JIRA-Home/plugins/installed-plugins
directory to$JIRA-Home/plugins/installed-plugins2
- Restart JIRA - This will re-create the the
$JIRA-Home/plugins/installed-plugins
directory but JIRA will start without any plugins - If the issue is no longer reproducible, Reinstall the add-on with the latest version through the Administration > Add-ons > Find new add-ons page.
- You may later delete the $JIRA-Home/plugins/installed-plugins2 directory which is no longer in use.
If the above steps do not resolve your problem
- Compress a copy of the following directory:
$JIRA-HOME/plugins/installed-plugins
- Collect a file listing of the above directory showing permissions such as:
ls -la
in Linux - Generate a Support Zip, or zip the $JIRA-HOME/log & $JIRA-INSTALL/logs directory
- Raise an issue with Atlassian Support, detailing steps attempted, and providing the above data for us to review.