Logging into Jira server returns 500 internal server error

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After upgrading JIRA 

  • You are unable to access JIRA
  • You are unable to start plugins
  • There are java.lang.NoSuchMethodError messages in the logs

The following appears in the atlassian-jira.log

java.lang.RuntimeException: javax.servlet.ServletException: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;
 
Caused by: javax.servlet.ServletException: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;
 
Caused by: java.lang.NoSuchMethodError: com.atlassian.jira.security.JiraAuthenticationContext.getLoggedInUser()Lcom/atlassian/crowd/embedded/api/User;

Diagnosis

  • The following Add-ons has been confirmed to be incompatible and cause the above problems:
    • jira-workinghours-plugin-1.5.5
    • jira-calendar-plugin-2.1.11
    • ephor-for-jira-1.2.3
    • hipchat-for-jira-plugin-6.31.0
    • bugdigger-jira-plugin-2.5.1
    • whoslooking-2.1

Cause

JIRA changed to use a different class causing incompatibility by any Add-on still using the deprecated API.

Resolution

If you can access JIRA 

  1. Open the Manage Add-ons page by navigating directly to:

    http://<jira-address>/plugins/servlet/upm

    Replace <jira-address> with the actual address from your JIRA instance.

  2. Update or disable any add-ons displayed as INCOMPATIBLE.
  3. If the page above is not accessible and shows the same error, follow the steps under Resolution 2 below.

If the suggestion above does not work

  1. Stop JIRA
  2. Go to your the $JIRA-Home/plugins/installed-plugins directory
  3. Rename the $JIRA-Home/plugins/installed-plugins directory to $JIRA-Home/plugins/installed-plugins2

  4. Restart JIRA - This will re-create the the $JIRA-Home/plugins/installed-plugins directory but JIRA will start without any plugins
  5. If the issue is no longer reproducible, Reinstall the add-on with the latest version through the Administration > Add-ons > Find new add-ons page.
  6. You may later delete the $JIRA-Home/plugins/installed-plugins2 directory which is no longer in use. 

If the above steps do not resolve your problem

  1. Compress a copy of the following directory: $JIRA-HOME/plugins/installed-plugins
  2. Collect a file listing of the above directory showing permissions such as: ls -la in Linux
  3. Generate a Support Zip, or zip the $JIRA-HOME/log & $JIRA-INSTALL/logs directory
  4. Raise an issue with Atlassian Support, detailing steps attempted, and providing the above data for us to review.


DescriptionAfter upgrading JIRA to 7.0, you are unable to access JIRA and JIRA returns a 500 Internal Server Error when attempting to access any Dashboard or login page
ProductJira
PlatformServer
Last modified on Sep 30, 2019

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