Logs Contain 'Received Message Carrying this JIRA Instance Fingerprint' Due to Mail Loop Detected
Symptoms
Application logs contain numerous occurrences of the following statement:
2009-05-26 08:55:06,321 JiraQuartzScheduler_Worker-0 WARN [service.util.handler.AbstractMessageHandler] Received message carrying this JIRA instance fingerprint (xxxxxxxxxxxxxxxxxxxxxxxxxxxxx)
Cause
The JIRA application code detected a possible looping of emails. Since version 3.13 of JIRA (see JRA-12467) every outgoing email is tagged with a custom header identifying the instance that is generating it. If any message containing such a header appear in any of the monitored incoming mailboxes, JIRA will log a WARN message and send a copy of the mail to the Forward:
address defined in the mail handler configuration.
Resolution
Identify and remove potential loop conditions such as:
- Remove the Notification schemes associated with the project as described in here.
- This is to stop the mail looping if there is any user account with the same email address of an email handler service.
- Check if there is any user accounts with the same email address of an email handler service.
- Search for the IMAP/POP server address at User Browser.
- Make sure the
Forward Email
option configured in the mail handler is not the IMAP/POP server address as shown in here. - Check if there are any automatic response systems under administrative control which respond to emails from JIRA.
- Change the email address associated to the user account causing the problem to a dummy address as described here.