Users are unable to assign Jira issues - The Assign button is missing
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Users in Jira are not able to assign issues to other users. There is no "Assign" button showing up on the screen:
Normally, there should be an Assign button as illustrated below:
Environment
Jira Server/Data Center on any version from 8.0.0.
Diagnosis
- The Permission Helper from Jira (accessible via the page ⚙ > System > Permission Helper) shows that the user has all the right permissions needed to assign issues:
- The Assignee field is also not showing up on the View issue screen, in the People Panel:
- Check the Field Configuration associated to the project the issue belongs to (via the page ⚙ > Issues > Field Configuration), and notice that the Assignee field is configured to be Hidden:
Cause
The reason for the problem is that the Assignee field is hidden from the field configuration.
Resolution
Navigate to the Field Configuration page
Select the field configuration corresponding to the project
Look for the Assignee field, and configure it to not be hidden
You should be able to see the Assign button in the screen after performing this.