Not receiving e-mail request in Jira Service Management using Exchange
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
E-mails are being rejected in Jira Service Management with vague error message in the logs and audit logs: The message was rejected because it has delivery status.
Steps to reproduce:
- Configure distribution list in exchange.
- Have mail forward from the distribution list to e-mail specified in JSD E-mail Channel.
- No Mail is received.
Diagnosis
Diagnostic Steps
- Check audit mail log Cog Icon>General>Applications>E-mail Request>Click view log for affected service project. You will see the following message:
- Check audit mail log Cog Icon>General>Applications>E-mail Request>Click view log for affected service project. You will see the following message:
- Checking the header information you will see the forwarded e-mail does not have a header.
- This is being rejected due to DeliveryStatusMailFilter that rejects the message as there is no return path specified. See Global Puller under Scheduled Jobs for reference.
Cause
The message is rejected and bounced due to No Return Path specified.
Resolution
- To resolve this issue, set the Return-Path value to one of the following values:
- ReportToOwner (the manager of the distribution group)
- ReportToOriginator (the originator of the email message)
Please be sure to vote, comment, and watch the feature request JSD-1749 for a more intuitive log error.