Notification: "Jira Service Desk is now Jira Service Management" keeps displaying
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Some of users are reporting that the notification: "Jira Service Desk is now Jira Service Management", keeps displaying even after closing the notification or clicking the Got It link to close it.
Environment
Jira Server / Data Center
All Browsers
Cause
The root cause is still unknown. When the notification is shown and the user acknowledges the alert, this value below is recorded in the database. However even though some users have this value set to true (by clicking the Got It option), the pop-up remains active.
{"shown":true}
Solution
Solution 1
You can see this value through this SQL Query in the database. If any user has the value of the propertyvalue column set as false, one of the option is to update the value to true, and see if that will fix the issue.
select * from propertyentry pe, propertystring ps where pe.property_key like 'chaperone:jsm.rebrand.notification%' and ps.id = pe.id
Solution 2
In case the affected user already have this value as true, it could be necessary to remove the database records related to that to re-trigger the insert, and potentially bypass any mapping problem going on.
- Create a backup of the database.
First find the ID of the affected user on this table running this query. Replace the username below with the user's username. Note down the ID.
select * from propertyentry pe, propertystring ps where pe.property_key = 'chaperone:jsm.rebrand.notification:username' and ps.id = pe.id
Delete the entries for this user on these both tables. Replace the ID value below with the ID from previous query above.
delete from propertystring where id in (ID);
delete from propertyentry where id in (ID);
- Ask the user to re-try, clicking in the button Got it, and verify if the pop-up persists.