ORA-00942 error with unknown plugin during backup restore
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When attempting a restore of an XML backup to a JIRA instance with an Oracle database, it fails to complete with ORA-00942 table or view does not exist
The following appears in the atlassian-jira.log:
2015-09-17 13:19:40,370 JiraImportTaskExecutionThread-1 ERROR anon 715x77x1 aa 1.1.1.1 /secure/SetupImport.jspa [jira.bc.dataimport.DefaultDataImportService]
Error during ActiveObjects restore
com.atlassian.activeobjects.spi.ActiveObjectsImportExportException: There was an error during import/export with <unknown plugin> (table ):
Caused by: java.sql.BatchUpdateException: ORA-00942: table or view does not exist
Diagnosis
There are third party add-ons that were already installed prior to restoring the XML backup.
Cause
A third party add-on is interfering with the upgrade process. It is currently unknown which add-on is causing this, as the error message does not show it:
There was an error during import/export with <unknown plugin> (table ):
Resolution
Remove all third party add-ons before restoring the XML backup.
- Stop JIRA.
- Make a backup copy of your add-ons in
$JIRA_HOME_Directory/plugins/installed-plugins/
- Delete the contents of the
installed-plugins
folder. - Restart JIRA and retry the XML restore.
If the previous failed attempt of the XML restore causes JIRA to be inaccessible (due to data being overwritten or incomplete restore) then you will need to reset the JIRA database to a blank database before retrying the XML restore.