Plugin License Incompatible with product license (wrong type) when using Open Source License.

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Plugins are not working properly after an upgrade in the JIRA instance, or UPM (Universal Plugin Manager).

Diagnosis

The UPM Version is: 2.18 or 2.17.15 and the following is appearing in the license status:

Cause

There is a known bug in these mentioned version of UPM causing this behaviour when using Open Source licenses of JIRA with Plugins.

Workaround

Downgrade to the bundled UPM version from JIRA by:

  1. Stop JIRA
  2. Remove the UPM jar from <jira-home>/plugins/installed-plugins
  3. Start JIRA

Resolution:

Upgrade the UPM plugin to version 2.18.1 when released.

Last modified on Jan 10, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.