Process to remove and reconnect JSM Chat (Assist) to a Slack Workspace

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

In some situations, removing and reconnecting Assist to your Slack Workspace will resolve permission issues when creating Triage & Request Channels, or when unable to access the Settings on the JSM Chat page.

Environment

JSM Cloud with a Project Connected to a Slack Workspace

Cause

Adding Assist to a Slack Workspace without Slack Admin permissions can cause the Integration with the JSM Project to display a blank page.

This is typically actioned by a User with Queue Admin Permissions only. Other similar issues can be resolved with the following Solution.

Solution

Removing and reconnecting Assist as a Slack Workspace Admin will allow the settings for Assist to be configured in the JSM Project's Chat Settings page as an example.

Because this Solution can affect multiple Projects, it is advised to try other methods first to resolve the issue, such as:

  • Using the Assist Bot's Commands in Slack to remove it from the relevant Triage & Request Channels.
  • Using the JSM Project's Chat Settings Page to make changes to Assist's configuration.

To remove Assist entirely from your Slack Workspace, which will affect every JSM Project using Assist in this Slack Workspace, the following Actions should be taken by your Slack Workspace Admin or the Owner of the Workspace:

  1. Navigate to the Slack App Directory to find the Assist Bot's page: https://site.slack.com/apps/ADBM44F4G-atlassian-assist
    Note: Replace "site" with your Slack Workspace name. Or search for Assist via the Browse button in the App Directory here: https://slack.com/apps
  2. Click the Configuration Tab.
  3. Scroll to the bottom and click Remove App.
  4. Click the red Remove App button that appears in the Modal that pops up.
  5. After the page refreshes, click Add to Slack.
  6. The Slack Workspace Owner will be redirected to the Atlassian Assist page. Click Connect Assist to Halp on the right.
  7. It will then ask to Sign in to Atlassian Assist with Slack so click Accept and Continue.
  8. A page will load that says Sign in to Halp where you can click the Sign in with Slack button.
  9. It will ask you to Sign in to Atlassian Assist with Slack again, so click Accept and Continue.
  10. Atlassian Assist will request permission to access your Slack Workspace, so click Allow.
  11. The Halp Tickets page will load here: https://site.halp.com/tickets. Nothing needs to be done on this page. The process is complete.
    Note: Replace "site" with your Slack Workspace name.

This will reset the Triage & Request Channels for all JSM Projects configured to use this Slack Workspace, along with any permissions Assist had to access your Slack.

Since the Assist Bot was reconnected to the workspace, the Project should load the Chat Page and show it as connected.

Further Reading

Last modified on Jan 5, 2023

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